MEP Digital Tools Guide Book Version 01 May 2018 MEP Digital Tools Guide Book Introduction This guide book has been produced to help guide users through how to access and use the various modelling and engineering tools that have been developed by the MEP Digital Transformation team. All the tools are based around working in an Autodesk Revit environment and this guide provides instruction on some of the basic software processes to enable non Revit users to access the tools. However, this guide does not provide a comprehensive guide to the use of Revit and users should refer to the learning modules on AECOM University for further knowledge about using the software. The first section of the guide provides instruction on some of the basic Revit model set up requirements. After this the tools that have been developed have been separated into 3 different groups: 1. Model Management - these tools provide a fast and AECOM standard way of setting up and using models for the non Revit user and significant operational efficiencies to certain tasks for more advanced Revit users. 2. Engineering Design - these tools provide automated engineering processes to complete design tasks in greatly reduced time lines while also increasing the quality of the information produced. 3. Co-ordination - these tools assist in the co-ordination process of designing projects and enable users to access and take advantage of the 3D information produced on a project MEP Digital Tools Guide Book Who to contact This page provides you with a list of the primary contacts to speak to regarding the use of any of the tools detailed in this document. We are building a list of office champions who will be a primary part of the development and communication of tools with the different teams around the business. If you do not see a representative for your office and would like to be a part of the digital team then please contact Peter Brickell to put yourself forward as an office champion for your area. MEP Digital Transformation Team Peter Brickell Ben Barfoot Office Champions London Tyler Street Piotr Deneka St. Albans Sam Townsend Manchester, Liverpool & Leeds Dan Cosgrove MEP Digital Tools Guide Book Basic Revit Guidance MEP Digital Tools Guide Book Basic Revit guidance 1. Opening an existing Revit model 2. Creating a new MEP Revit model from an architects model 3. Accessing and running a script / tool - basics 4. Printing MEP Digital Tools Guide Book Opening an existing Revit model This page outlines the basic details for opening an existing Revit model already set up for your project Step 1: Go to the windows button on your desktop Select Revit 2018* Navigate to Revit 2018* and click on it Or *Watch It Note: Please check with the project model manager which version of Revit the project is in. Never upgrade a model yourself if you are asked to during the opening of a file If it not shown in your list select "All Programs" Step 2: Revit will open to give you a screen as shown here. Select the open button Never select your model from this location even if it is shown here Step 3: Navigate to your model as you would normally in windows and select open Ensure this option is ticked if available Step 4: If presented with this screen select "Override existing file" and your model will open in a view like below MEP Digital Tools Guide Book Creating a new MEP Revit model - sheet 1 of 4 The following pages outline the basic details for creating a new MEP Revit model and linking in architectural information to enable options or analysis to be tested and for Revit to be used as an early stage design tool. This guide does not cover all the steps for setting up a central file for multiple people to use through the design process. Please talk to your local BIM manager for support in setting up project models. Step 1: The following window will appear: Open Revit (refer to Step 1 of the "opening and existing Revit model" guide if you need help with this step) Hit "New" on the start screen Select "Browse" Navigate to the location below and select the 2018 template in this location and hit "open" then "ok" on the next screen Z:\_EMIA\Digital\_Resources\Autodesk\Revit\2018\Templates\ MEP Step 2: Select "Level 0" in the project browser Delete everything in the view by clicking the mouse in on corner of the view and dragging to the opposite corner before letting go of the mouse. Then press the "Delete" button on you keyboard Press "Ok" when this dialogue appears MEP Digital Tools Guide Book Creating a new MEP Revit model - sheet 2 of 4 Step 3: In the tool bar at the top of the screen go to the "Insert" tab and click on the "Link Revit" button Use the dialogue box to navigate to your architectural file. Select it and press the "Open" button The architectural model should now appear in your Revit view Step 4: Click on the architectural model to select it. The architectural information should now be highlighted blue as shown here Click the "Edit Type" button This dialogue box will be shown: Mark the tick box to make the model "Room Bounding" Click "Ok" MEP Digital Tools Guide Book Creating a new MEP Revit model - sheet 3 of 4 Step 5: In the tool bar at the top of the screen go to the "View" tab and click on the "Section" button Click once in your model view and then again the other side of the view to draw a section Right click on the new section line your have created and this pop up will appear. Link "Go to view" in the pop up A section view of your model will now appear on your screen but no levels will be showing and these need to be copied to the MEP model to complete the set up. Step 6: In the section view in front of you press "VV" on your keyboard and the visibility settings window will appear Click on the "Filters" tab Click on the tick box next to "Levels/Grids" to make them visible in your view Click "Ok" MEP Digital Tools Guide Book Creating a new MEP Revit model - sheet 4 of 4 Step 7: Go to the "Collaborate" tab at the top of your screen. Select "Copy/Monitor" and select the "Select Link" option Click on any part of the architectural model in your section view on your screen and the toolbar at the top of your screen will change to look like this: Press the "Copy" button Now click on each of the level lines within your section view that you want to copy. It is recommended that you just copy the FFL's but you can copy any of the levels within the architects model When you have selected all the levels you want to copy press "Finish" in the toolbar to complete the process This has completed the process of setting up an MEP model with an architectural link and with all the 3D information linked through in order to be used for design and analysis MEP Digital Tools Guide Book Accessing and running a script/tool This page outlines the basic details for opening and running all MEP digital scripts/tools via Revit Step 1: Within your Revit session go to the "Manage" tab at the top of the screen and click on the "Dynamo" button to launch Dynamo Step 2: The Dynamo window will appear. Select open and navigate to the tool you want to use. All tools are stored centrally here: Z:\_EMIA\Digital\_Customisation\Dynamo\Revit Step 3: The tools will be opened in Dynamo Follow the instructions Press "Run" MEP Digital Tools Guide Book Printing This page outlines the basic details for printing views and sheets from Revit Press "CTRL P" or go to the file tab at the top of the screen and select print Select the printer your want to use. (It is recommended to print to PDF for record) If printing to PDF the options in this area will be available to enable you to print each view separately or combined into one document and set the location for the PDF to be saved Press the "Setup" button to get this dialogue box where you can enter standard print settings such as paper size etc. In the "Print Range" options you can set what you want to print. If you press "Select" you get this dialogue box where you can select all the views and sheets you want to print When the options have been set press OK to print your information MEP Digital Tools Guide Book Model Management / Efficiency Tools MEP Digital Tools Guide Book Model management / efficiency tools 1. Creating user views 2. Creating worksets 3. Creating spaces within the model 4. Automatically pinning elements 5. Management of view templates 6. Drawing production - initial set up 7. Renaming documents 8. Purging a model for issue MEP Digital Tools Guide Book Creating user views This tools creates views in the model dedicated to the user running the tool. This enables the user to create plans and 3D views in seconds labelled with the users name for the user to work inside the model with. Views created in this way control the number of unwanted views in the model that slow down the model for all users Setup: Using the "opening and existing Revit model" and " accessing and running a tool/script" guides open the "Create-UserViews" tool from the model in which you want to create the views Step 1: The open script should look like this: Instructions Select whether you want floor plans, ceiling plans or a 3D view Select "Run" Result: A set of views will have been created in the "project browser" under your name for you to work in MEP Digital Tools Guide Book Creating worksets Worksets in Revit are the equivalent of layers in AutoCAD or levels in Microstation. They define the groupings within which different elements are drawn. This script creates the AECOM standard worksets automatically in the model for the user giving consistency throughout our projects without needing to manually create them. Setup: This tool should get used at the beginning of setting up a new model. It can also be used on an existing model you are working on that doesn't have the worksets that you need. Once you have followed the guidance in the "creating a new Revit model", "creating a central file" and " accessing and running a tool/script" guides open the "Create-Worksets" tool from the model in which you want to create the worksets. Step 1: The open script should look like this: Instructions For more advanced users the list of worksets that will be created is listed here. This list can be edited to create more or less worksets as required or if there is a project specific requirement. For normal use it is recommended that the script is just run with the standards set worksets as they are given. Select "Run" Result: At the bottom of your Revit window this icon will now be coloured The drop down list next to the icon will now be populated with all the worksets MEP Digital Tools Guide Book Creating spaces within the model Spaces within a Revit model are created from the architectural model information and are used in the MEP model to store information that can be used within Revit to generate modelling and documentation information. This tool automatically creates all the spaces within the model and is an important modelling step for some of the engineering tools detailed later in this document. Setup: Once you have followed the guidance in the "creating a new Revit model" and " accessing and running a tool/script" guides open the "Create-Spaces" tool from the model in which you want to create the spaces. Step 1: The open script should look like this: Instructions Select "Run" The tool needs to find the architectural file linked to your model. To do this it needs some text from the file name of the architectural file typed in here. MEP Digital Tools Guide Book Automatically pinning elements Pinning elements within Revit is the equivalent of freezing or locking a layer in AutoCAD. It is a process for locking things within your model that you would not typically ever want to edit e.g. the architectural model or the grids. This tool automatically sweeps through the model to pin all the typical items and it is recommended the novice Revit users run the script every time they open a model. It is also suggested that more experienced model managers run this script on a regular basis depending on the number of users to ensure elements within the model are not accidentally moved. Setup: Using the "opening and existing Revit model" and " accessing and running a tool/script" guides open the "PinElements" tool from the model in which you want to pin all the elements Step 1: The open script should look like this: Instructions Select what you want to pin. It is recommended to use the default setting and pin everything in the list. Select "Run" MEP Digital Tools Guide Book Management of view templates - sheet 1 of 2 View templates within Revit control how every drawing and view look on screen and when printed. There are hundreds of different setting options for each template within a model and it can be laborious task to edit these to get documents ready for issue and a difficult task to manage across projects with more than one Revit file. This tool exports all the template information to an excel document where multiple templates can all be edited quickly at the same time and then re-imported back to change the setting inside the Revit model. Setup: Using the "opening and existing Revit model" and " accessing and running a tool/script" guides open the "ViewTemplates" tool from the model in which you want to edit the view templates in. Go to the location of the tool (given below) and copy the excel file a local location you can access. Either in the project area on the server or a folder on you computer. Z:\_EMIA\Digital\_Customisation\Dynamo\Revit\01-Model-Management\ZZ-UKI-Manage-ViewTemplates Step 1: The open script should look like this: Instructions Select the excel file that you saved in this box Set the options in this box to "false" to export the view template information from this model Select "Run" Model management suggestion: Once you have a Revit model set up with all the correct view template settings, use step 1 to export all these settings to the excel file. Save a copy of this file within the project folder so that later in the design process, when it is time to issue drawings but a number of designers have been using the model and have edited the templates, you can quickly and easily re-set all the settings in time to issue the documentation. MEP Digital Tools Guide Book Management of view templates - sheet 2 of 2 Step 2: Open the excel and use the tabulated information to change any setting you require in any or all of the view templates in the model. Re-save the excel once complete. View templates are listed across the top of each page If you want an element to show in a template then mark the box with an "x". If you don't want it to show then leave it blank The tabs at the bottom correspond to the different tabs you would normally edit in Revit Step 3: Go back to the script in Revit, set it to import data and re-run it to bring your excel changes back into the model: Instructions Select the excel file that you saved in this box Set the options in this box to "true" to export the view template information to this model Select "Run" Note: The same excel file can be imported into multiple models to make everything on a project with more than one model look the same without having to manually change all of them. To do this, once you have an excel file you have filled out, skip steps 1 & 2 and run the import on each model. MEP Digital Tools Guide Book Drawing production - initial set up The current process for creating drawings is for someone to put together a drawing list manually, trying to think of all the drawings required across the project and trying to make sure they all sit within the complex drawing numbering system. Then a Revit user has to manually create and populate all the views and sheets within the model. This tool removes this whole process. In this tool you select the packages of information you require and the tool will create and populate all the drawing information for the user into the model. Setup: Using the "opening and existing Revit model" and " accessing and running a tool/script" guides open the "CreateDrawings" tool from the model in which you want to make all the drawings Step 1: Instructions Select "Run" Step 2: Fill in the top boxes selecting the sheet size and drawing scale Select the levels from the model you want to create drawings for my checking the tick boxes Mark the scope boxes your require. If it is a large project where more than one sheet per floor is need you need to tick multiple boxes and number them Select the different packages that you want to create drawings for e.g. pipework or containment etc. by checking the tick boxes Fill in these boxes with how you want them to appear in the drawing numbers and titles. Select "Accept" to create all the sheets in your model MEP Digital Tools Guide Book Renaming documents Pinning elements within Revit is the equivalent of freezing or locking a layer in AutoCAD. It is a process for locking things within your model that you would not typically ever want to edit e.g. the architectural model or the grids. This tool automatically sweeps through the model to pin all the typical items and it is recommended the novice Revit users run the script every time they open a model. It is also suggested that more experienced model managers run this script on a regular basis depending on the number of users to ensure elements within the model are not accidentally moved. Setup: Using the "opening and existing Revit model" and " accessing and running a tool/script" guides open the "PinElements" tool from the model in which you want to pin all the elements Step 1: The open script should look like this: Instructions Select what you want to pin. It is recommended to use the default setting and pin everything in the list. Select "Run" MEP Digital Tools Guide Book Purging a model for issue Increasingly our 3D model information has to be issued on a weekly basis during the detailed design phase of a project. Each time this task is done the model has to be copied and manually purged of data such as linked files, views and sheets etc. This script completes this task automatically. Setup: Using the "opening and existing Revit model" guide, open the model you want to purge and do a "save as" to the location that you are going to issue the model from. Then, using the "accessing and running a tool/script" guides open the "ReadyForIssue" tool from the model in which you want to purge all the elements Step 1: The open script should look like this: Instructions Select what you want to purge Make sure this is set to false Select "Run" Step 2: Review the text inside the "Debug" window to confirm you are happy with what is being removed Change this to "true" and run the script again to apply the changes to the model MEP Digital Tools Guide Book Engineering Design Tools MEP Digital Tools Guide Book Engineering design tools 1. Space calculation and strategy documentation 2. Automatic plantroom generation MEP Digital Tools Guide Book Space calculation and strategy documentation - sheet 1 of 5 The following pages guide you through the process of extracting geometrically information from a model that can be used with a spreadsheet to automatically calculate heating, cooling and ventilation loads for the spaces in the building*. This information can then be brought back into the model to generate coloured strategy drawings for communication with clients and architects. * The spreadsheet calculations are currently only created for an office building but the strategy documentation can be created for any building type Setup: Go to the following location and everything in this folder to a local location you can access. Either in the project area on the server or a folder on you computer. Z:\_EMIA\Digital\_Customisation\Dynamo\Revit\02-Engineering-Tools\BS-UKI-SpaceCalculation Where you save this information to will be referred to as the "saved location" through the rest of this guide. To run this tool you need to install some additional add-ins to your Dynamo installation. These are called "Packages". In the information you have copied to your saved location there is a "Packages.zip" file. You need to unzip this file to your saved location. Open Dynamo (via your Revit sessions as normal) and go to the "Settings" tab at the top of the screen Select the "Manage Node and Package Paths..." option This dialogue box will appear: Select the "+" sign and use the file option dialogue to navigate to the unzipped "Packages" folder in your saved location Press "Accept Changes" Note: This step of adding in "packages" to your Dynamo only needs to be done once and does not need to be repeated again MEP Digital Tools Guide Book Space calculation and strategy documentation - sheet 2 of 5 Step 1: Open the Revit file that you want to do the calculations or strategy drawings for and make sure that it has spaces created in it. If required create the spaces in the model - use the "creating spaces within the model" guide to help with this. Using the "opening and existing Revit model" and " accessing and running a tool/script" guides open the "SpaceCalculationDataExport" tool from the model in which you want to do your calculations. Instructions Press "Browse" here to navigate to your excel file in your saved location Press "Run" Step 2: Open the excel file from your saved location The "Export Data" tab should now be populated with all the space data from you model similar to what is shown here Select the "Import Data" tab MEP Digital Tools Guide Book Space calculation and strategy documentation - sheet 3 of 5 Step 3: In this tab, fill out all the drop down options for each space in the building Select the space type to match the space from the model Select the lighting level for each space Select the ventilation, heating and cooling strategy for each space Step 4: Select the "Calculation Inputs" tab Edit any of the defaults in the green cells to suit the basis for design for your project Go back to the "Import Data" tab and you will see that there is a heating, cooling and ventilation load given for each space in the building based on all the inputs you have now completed MEP Digital Tools Guide Book Space calculation and strategy documentation - sheet 4 of 5 Step 5: The following steps will import the completed information from your spreadsheet back into the model if you wish to create strategy drawings Instructions Press "Browse" here to navigate to your excel file in your saved location that you completed in the steps above Press "Run" Step 6: Select a view that you want to make into a strategy drawing Select the view template button to bring up the view template dialogue Scroll through the view template options and select the strategy you want to display in your view Press "Ok" MEP Digital Tools Guide Book Space calculation and strategy documentation - sheet 5 of 5 Step 7: Select the "Analyse" tab at the top of the screen Select the "Legend" button in the "Color Fill" area Click where ever in the view you want the legend to be placed Repeat steps 6 & 7 on different sheets to create all the strategy drawings you require. MEP Digital Tools Guide Book Automatic plantroom generation - sheet 1 of 5 The following pages guide you through the process to automatically generate and document 3D plantroom design information. Unlike the other MEP digital tools, this one does not require any existing Revit or model information and can be used as a completely standalone tool right from the earliest stages of the project. Setting Up: Go to the following location and copy everything in this folder to a local location you can access. Either in the project area on the server or a folder on you computer. Z:\_EMIA\Digital\_Customisation\Dynamo\Revit\02-Engineering-Tools\BS-UKI-SpaceAllowance Where you save this information to will be referred to as the "saved location" through the rest of this guide. Make sure that you have the latest versions of the Space Allowances software and the Space Allowances Add-in to Revit installed on your computer. Both are available from the software centre on your computer. Step 1: Open the excel file in your saved location Fill in the duty details in line with the notes provided Select the type of plantroom you want in the drop down Fill out a line for each plantroom Type in the additional details (the tool can do up to 25 plantrooms in one go*) Save your completed spreadsheet back to your saved location *Watch It Note: Do not add unnecessary plantrooms as the more you have the longer the tool will take to run. Step 2: The following window will appear: Open Revit (refer to Step 1 of the "opening and existing Revit model" guide if you need help with this step) Hit "New" on the start screen Select "Browse" Navigate to your saved folder location and select the only Revit file in this location and hit "open" then "ok" on the next screen MEP Digital Tools Guide Book Automatic plantroom generation - sheet 2 of 5 Step 3: (refer to the "accessing and running a script/tool" guide if you need further help with this step) Open Dynamo and navigate to the saved location and open the "CreateFile" script. Follow the instructions and run the script Instructions Press "browse" here to navigate to your excel file in your saved location to load Press "Run" Step 4: Running the script above will open the software Space Allowances and generate all the plantrooms from your excel file in the software. Take the time now to review each plantroom and make any project specific adjustments required. When finished save the file to your saved location. MEP Digital Tools Guide Book Automatic plantroom generation - sheet 3 of 5 Step 5: (refer to the "accessing and running a script/tool" guide if you need further help with this step) Open Dynamo again and navigate to the saved location and open the other script in the folder Follow the first part of the instructions and run the script Instructions Press "browse" here to navigate to your space allowance file in your saved location to load Make sure this is set to false Press "Run" Step 6: Select the plantroom you want to import Go back to Revit and in the Add-Ins tab at the top of the screen select Space Allowances and navigate to your file in your saved location Select the equivalent plantroom here *Watch It Note: If you have modified the wall positions of the plantrooms in space allowances then they will not always align automatically with the spaces in Revit. This will be shown in the import image and can be easily adjusted by manually editing the x and y figures. These two screens will pop up. Just hit "Yes" to both Once the import is complete this screen will appear. If you have more plantrooms to import then repeat this step for each one. Otherwise press "No". MEP Digital Tools Guide Book Automatic plantroom generation - sheet 4 of 5 Step 7: (refer to the "accessing and running a script/tool" guide if you further need help with this step) Go back to Dynamo and the last script you had open (it should still be open unless you closed Dynamo). Follow the last part of the instructions and run the script Instructions Press "browse" here to navigate to your space allowance file in your saved location to load Make sure this is set to true Press "Run" Step 8: Back in your Revit file enter the project number into the front screen Double click on the "Front Sheet" tab Using the project browser in the corner of your screen Note: If you want to view your plantroom information in Revit double click on the individual tabs Enter the project information by clicking on each piece of text and typing the details At this point you should save you Revit file to your saved location MEP Digital Tools Guide Book Automatic plantroom generation - sheet 5 of 5 Printing: (refer to the "printing" guide if you need further help with this step) Press "CTRL P" or go to the file tab at the top of the screen and select print Select the printer your want to use. (It is recommended to print to PDF for record) If printing to PDF, select combine into a single file and browse to your saved location - this is where the PDF will be created Press the "setup" button and select "A1" in the drop down. Then press OK in this window Click the Selected views/sheets option. You will see the "Space Allowance - Print Set" text appear. Everything else has already been set up as part of the tool When the options have been set press OK to print your information MEP Digital Tools Guide Book Co-ordination Tools MEP Digital Tools Guide Book Co-ordination tools 1. Navisworks view creation MEP Digital Tools Guide Book Navisworks view creation This tool creates views for every individual space inside model that can be loaded into the exported Naviswork file of the model. These views can then be used to navigate quickly and easily around the model in Navisworks. The views can then also be used to create model comparisons and other analysis within Navisworks Setup: Using the "opening and existing Revit model" guide you need to open the Revit model that your Navisworks file was exported from*. Then use the " accessing and running a tool/script" guide open the "Create-NavisworkViewsPerSpace" tool from the model in which you want to pin all the elements Step 1: The script is going to generate an xml file from the Revit model that can be loaded into Navisworks to give the views of each room The open script should look like this: Instructions Click "Browse" to select where you want the xml file to be saved and what you want it to be called If the model has shared co-ordinates set this to "True" Type in the folder name that you want the views to appear in Navisworks Select "Run" Step 2: Right click in the "Saved Viewports" window in your Navisworks file and select the "Import Viewports" option Navigate to your saved xml file and select option. You should now have the viewports to use in your Navisworks file
0
Puede agregar este documento a su colección de estudio (s)
Iniciar sesión Disponible sólo para usuarios autorizadosPuede agregar este documento a su lista guardada
Iniciar sesión Disponible sólo para usuarios autorizados(Para quejas, use otra forma )